Important notice for Internet Explorer users

For security reasons, we will perform an update to MijnPost in the first six months of 2017. As part of this update, a new version of the TLS protocol by Salesforce will be deployed. This is necessary because support by Salesforce for the current version (TLS 1.0) will be discontinued in the near future.

Need help?

Please contact our customer service by phone at 088 868 68 68, or send an e-mail to business@postnl.nl.

What does this mean for you?

If you are running Internet Explorer 9 or 10, you may be unable to log on as of 2 April 2017. You are therefore advised to update your browser to Internet Explorer 11 or higher. If you are unable to perform an update yourself, please contact your IT department.

How can I tell which version of Internet Explorer I am running?

Please follow these instructions to identify your IE version.
  1. Launch Internet Explorer
  2. Click on ‘Extra’ (the small gear icon located in the top right corner of your browser window)
  3. Click on ‘About Internet Explorer’
The version number will now be shown.

Already running IE11?

Click here to make sure that you still can log in as of April 2 2017. If everything is working properly, the following message will be shown.

TLS1

If the screen below is shown, we advise you to change your browser settings manually to ensure compatibility with MijnPost. Instructions on how to change your browser settings can be found here (opens in a new window).

TLS2

Unable to update Internet Explorer?

In that case we advise you to change your current (IE9 or IE10) browser settings manually to ensure compatibility with MijnPost. Instructions on how to change your browser settings can be found here (opens in a new window).